Go to:
Previous Item
Current News
Next Item

Adobe pulls Lightroom 1.4
By
(Monday, March 17, 2008 - 10:47 EDT)

A post today on the official Adobe Lightroom journal notes that the company has temporarily withdrawn its latest update to the popular Photoshop Lightroom application.

Adobe Lightroom 1.4 apparently contained several significant bugs that slipped through the testing process. These are as follows, to quote the Lightroom team:
  • "EXIF Time Stamp Error: There is an error in the EXIF time stamp update technology that causes Lightroom to believe that the files are out of sync with the correct time stamp as displayed in Lightroom. Any ensuing metadata update will attempt to incorrectly modify the EXIF time stamp in the original raw file itself. This is the only metadata field that Lightroom will write to an original proprietary raw file. This error will not impact the integrity of your image data. The Camera Raw plug-in also will incorrectly change the EXIF time stamp in files converted by the plug-in. The information written to the XMP sidecar files or XMP metadata in the converted files will remain correct."
  • "DNG Conversion Error(Windows Only): With the latest version of the Lightroom 1.4 and Camera Raw 4.4 applications, Adobe has included technology to verify that the image data in a DNG file is unchanged from when it was originally converted to DNG. Unfortunately, when converting to DNG using Lightroom 1.4 on Windows, the application will write an incorrect verification tag to describe the image data. When Lightroom attempts to work with those files in the Develop module, the application reads that incorrect tag, believes that there is something wrong with the raw data and will present an error. Rest assured, there is nothing wrong with the integrity of your image data or metadata. For those that have already converted their files to DNG using Lightroom 1.4(Windows only) we recommend using the DNG 4.3.1 converter to convert the DNG files you’ve created with Lightroom 1.4."
  • "Olympus Conversion Error: There is an error in converting Olympus JPEG files to other formats in Lightroom 1.4 and the Camera Raw 4.4 plug-in."
Adobe is recommending all users who installed the update to revert to using the previous Photoshop Lightroom version 1.3.1.

In a related note, users of Camera Raw 4.4 and the DNG 4.4 Converter are also being recommended to revert to the previous 4.3.1 versions unless they are "in immediate need of the updated camera support available" in the 4.4 releases.

For more, read the Lightroom Journal entry.

Thanks to regular correspondent Peter Burian for emailing us a heads-up to this news...

Go to:
Previous Item
Current News
Next Item