Iridient Digital releases RAW Developer 1.9.3 for Mac OS X

posted Monday, November 28, 2011 at 12:05 PM EST

Press Release

Iridient Digital's logo. Click here to visit the Iridient Digital website!Pacific Grove, CA, November 28, 2011 -- Iridient Digital, Inc. has released RAW Developer 1.9.3 an update to our critically acclaimed RAW image processing software for Mac OS X.

RAW Developer 1.9.3 is a maintenance update to the previous 1.9.2 release. This update includes support for new camera models, performance improvements to lossless jpeg decompression (used by numerous camera models) and a couple minor bug fixes. The newly supported cameras include:

  • Canon PowerShot S100

  • Fuji X10 and F600EXR

  • Nikon P7100, J1 and V1

  • Olympus E-PM1

  • Panasonic DMC-FZ150

  • Ricoh GR Digital IV

  • Samsung NX200

  • Seitz 6x17, Roundshot D2x and Roundshot D3

  • Sony NEX-7

RAW Developer 1.9.3 can be downloaded from:
http://www.iridientdigital.com/products/rawdeveloper_download.html

Further information about RAW Developer can be found online at:
http://www.iridientdigital.com/products/rawdeveloper.html

Release notes for this and all prior RAW Developer releases are available here:
http://www.iridientdigital.com/products/rawdeveloper_history.html

This release is a paid upgrade for previously registered users who originally purchased a license more than 24 months ago (prior to November 2009). RAW Developer can be used unregistered in "demonstration" mode. When unregistered RAW Developer is fully functional, however all exported images will be watermarked.

Upgrades are available to previously registered users for the discounted price of $75 US by requesting a discount code from sales@iridientdigital.com. New licenses can be purchased for $125.00 US securely through RAW Developer by selecting "Purchase..." from the File menu or securely online through our web store at:
<http://store.eSellerate.net/s.aspx?s=STR9488905116>

RAW Developer 1.9.3 is a universal binary application and fully supports Mac OS X systems based on both PowerPC and Intel processors. 64-bit support requires Mac OS X version 10.5 or later and a 64-bit capable Intel processor (Core 2 Duo or later).

RAW Developer 1.9.3 requires Mac OS X version 10.4.10 or later and a PowerPC G4 or G5 processor or an Intel processor.